Upload file size limit

Permalink 2 users found helpful
Is there an upload file size limit? Here's my problem...

I've uploaded numerous photos before without a problem. However, I recently tried to upload a 3mb image file. It uploads file and I get a success message and I check the server and the file is physically there....but, it is not listed in the file manager. It seems to possibly related to the size of the file, as this is the largest file that I have uploaded and all the others have been file. Any thoughts as to what might be occuring.

jgarcia
View Replies:
LucasAnderson replied on at Permalink Reply
LucasAnderson
I'm having the same problem but the limit seems to be 1.5 MB
gueric replied on at Permalink Reply
i had exactly the same problem you describe, but the coupable wasn't the file size, instead it was the file name. i can't remember correctly because now i avoid special caracters, space, underscore, hyphen, numbers and all is fine.

the coupable was one, but maybe two or tree of those ones.

hth
LucasAnderson replied on at Permalink Reply
LucasAnderson
Definitely not the filename, it is any file over 1.5 MB

All my settings in php.ini seem correct as they allow up to 8mb per upload.

I wonder if there is something up with the connection to the database, as the file gets uploaded but it doesn't create a record for it in the database?
andrew replied on at Permalink Reply
andrew
These are php settings that you'll want to make sure are set correctly... we currently have them all set to around 60 megs..

post_max_size
upload_max_filesize
codytesnow replied on at Permalink Reply
codytesnow
Sorry for the obvious question, but I'm new to this...where might I find these settings?
jgarcia replied on at Permalink Reply
jgarcia
They would be in your php.ini file. If you're running your own server, you can just edit this file directly. if not, you can add the something like this to your .htaccess file:

php_value upload_max_filesize 20M
royjaison replied on at Permalink Reply
I am sorry to ask, this is completely new to me. where is this php.ini file. where can I find this in the website. I dont see anywhere can please tell me the step by step procedure? thanks in advance!
Tony replied on at Permalink Reply
Tony
php.ini isn't located within your website. it's somewhere else on your server. if you're running mamp or xampp or some local desktop server, it may be in some kind of conf directory or some apache directory. on my linux box it's at /etc/php.ini

BTW, if you can't get uploads to work after changing the max size settings, try raising the default timeout settings:

max_input_time
max_execution_time
Tony replied on at Permalink Reply
Tony
or if php safemode is disabled for your site, instead of editing the php.ini setting, i think you could just add snippets like this to your site.php file:

ini_set('max_input_time',600);
codytesnow replied on at Permalink Reply
codytesnow
Perfect.
mario replied on at Permalink Reply
mario
make sure to try the first option Andrew mentioned too and change the post_max_size in your php.ini as in:
post_max_size = 50M


or in your htaccess:

php_value post_max_size 50M


This worked on one of my sites where upload max did not.
RedInvasion replied on at Permalink Reply
I cant upload a video cause concrete Upload Max File Size: 10M
and Post Max Size: 8M and in my file manager in unlimited so its not the server fault its the concrete5 pleas help.

BTW: the php_value post_max_size 50M in my .htaccess file i get a 500 server error. pleas help.
pixelhandler replied on at Permalink Reply
pixelhandler
I just added to my .htaccess in the site root the following code...
# php settings
php_value post_max_size 30M
php_value upload_max_filesize 30M

Seems to work fine I was able to upload a 10MB PDF file.
asankaw replied on at Permalink Reply
asankaw
I got the same issue. Thank u so much for your answer. It worked. :)
tsilbermann replied on at Permalink Reply
tsilbermann
that works for me as well - I've got the same answer from my provider
CheSimpson replied on at Permalink Reply
I had the issue too. Removing the 5 worked right away. Thanks!
jfhencken replied on at Permalink Reply
jfhencken
You can go to
Dashboard » System & Settings » Environment Information
and check the values for:

post_max_size - 10M
upload_max_filesize - 10M

I have a site on JustHost.com (BlueHost.com) which runs PHP v5.4.19

First I placed the following lines in a php5.ini file and placed it in /public_html and that had no effect.

file_uploads = On
upload_max_filesize = 100M
post_max_size = 100M
upload_tmp_dir = /tmp/


Next I changed the file name from php5.ini to php.ini and everything worked fine. A recheck of the Environment Info then read:

post_max_size – 100M
upload_max_filesize - 100M