What is this error and how do I solve it?

Permalink
PHP Warning: PHP Startup: Unable to load dynamic library '/usr/php/53/usr/lib64/php/modules/imagick.so' - /usr/php/53/usr/lib64/php/modules/imagick.so: undefined symbol: zend_replace_error_handling in Unknown on line 0

No clue can anyone help?

View Replies:
fastcrash replied on at Permalink Reply
fastcrash
i have no idea either
is your Imagick library load in your hosting php.ini?
tlamb replied on at Permalink Reply
Yes at the very bottom of the php.ini file

[start code]

[dba]
;dba.default_handler=

; Local Variables:
; tab-width: 4
; End:

zend_loader.disable_licensing=0
extension=imagick.so
zend_extension=/usr/php/53/usr/lib64/php/modules/ioncube_loader_lin.so
zend_extension=/usr/php/53/usr/lib64/php/modules/ixed.lin
zend_extension=/usr/php/53/usr/lib64/php/modules/ZendGuardLoader.so

[end code]

The issue I am having is that I can not access the dashboard of my site. I have tried everything else the forum has suggested and hired TWO other individuals who were unable to solve the problem. This is my last resort and the only error I see so Im hoping this is the culprit lol!
mhawke replied on at Permalink Reply
mhawke
Shot in dark:

Are you sure that the php.ini file posted is the actual php.ini file being used by the site. To find out, create and upload file called 'phpinfo.php' containing only this line of code:

<?php phpinfo(); ?>


Hit 'www.yoursite.com/phpinfo.php' with your browser and see what php.ini file is actually in use. Look for 'Loaded Configuration File'. Some hosts don't let you change the PHP settings.
fastcrash replied on at Permalink Reply
fastcrash
Wow! you hired TWO other individuals who were unable to solve the problem?

you can test with php script, add it in phpinfo.php above, so it not include you c5 site, just to make sure imagick is run properly

header('Content-type: image/jpeg');
$image = new Imagick('image.jpg');
// If 0 is provided as a width or height parameter,
// aspect ratio is maintained
$image->thumbnailImage(100, 0);
echo $image;
//phpinfo(INFO_MODULES);
mnakalay replied on at Permalink Reply
mnakalay
Another shot in the dark:
it seems as if the php.ini was trying to load imagemagick while it's not installed on the server.

What piece of code or add-on do you have that would require imagemagick?

Did you get the content of your php.ini from somewhere else and copied it?

You should check if your host actually provides imagemagick, if not, this piece of code in php.ini is not needed

Then you should check whether you nee it or not.
tlamb replied on at Permalink Reply
I did what mhawk and fast track suggested. Is it safe to post the link to this page I created so you guys can take a look at it?
tlamb replied on at Permalink Reply
I am running a few sites off of the same domain which I can see may cause a problem in trouble shooting this right? Or do all of my sites run from the same php.ini file?
mhawke replied on at Permalink Reply
mhawke
There shouldn't be any harm in posting a link to your diagnostic page. I believe most servers would run the same php.ini for all 'domains' but I guess that would depend on how you've set everything up.

I'm no Apache expert on running multiple 'domains'. If they're just in subdirectores off your root such as 'www.yoursite.com/site1', 'www.yoursite.com/site2', etc., then they will all be using the same php.ini (I think)
tlamb replied on at Permalink Reply
http://www.nmtmarketing.biz/phpinfo.php

Here it is. Im a little lost on how to find whats going on based on this.
tlamb replied on at Permalink Reply
I dont know what the imagemagic is or where it came from. Im guessing it may be from the real estate ad on I am using but I dont think that would have anything to do with my 'no dashboard' issue would it? Im checking with my hosting now.
mhawke replied on at Permalink Reply
mhawke
Your phpinfo seems to indicate that imagick is installed. I googled the error message and it seems to only come up in other people's error.log files. There was one post that indicated that this error can occur when the php.ini contains a reference to imagick when indeed the imagick modules were not installed.

Try removing this line from your php.ini

extension=imagick.so


It might not be needed by your site but I think this is a job for your host to figure out.