When I add images they do not appear in TinyMCE editor, but appear fine when publishing a page or saving a block. {CCM:BASE_URL} seems to be the problem.

Hi everyone,

Thanks in advance for help.

I add images to my site using TinyMCE (along with the plugin, Moxiemanager). When actively editing a block in TinyMCE, the image I added will show up as 'broken' inside the editor. However, when saving the block/publishing the page, the image shows up just fine on the actual page. It seems that everytime I add an image into the TinyMCE editor, the file path IN THE EDITOR gets changed from mysite.com/image.jpg to {CCM:BASE_URL}/image.jpg.

If the path is mysite.com/image.jpg, the image shows up fine in the editor. If it's {CCM:BASE_URL}/image.jpg, however, the image is 'broken' in the editor. It seems that Concrete5 automatically converts my file paths to replace mysite.com into {CCM:BASE_URL}.

How can I stop this automatic conversion? No matter how much I configure Moxiemanager and tinyMCE.init, {CCM:BASE_URL} is always placed somewhere in the file path.

View Replies:
hutman replied on at Permalink Reply
Have you tried defining BASE_URL in your /config/site.php? Usually that will solve the problem, having that in there is a good thing, not something you want to get rid of, because if you ever move the site it won't have hard coded URLs in there.
miteff replied on at Permalink Reply
That did not fix it for me. Any luck Goodlyd?
goodlyd replied on at Permalink Reply
Unfortunately, that's one of the first things I tried and it didn't work. I was on hiatus for a while, but I'm back and I'm going to continue looking for a solution. I'll let you know if I do find one (hopefully, I will!).
goodlyd replied on at Permalink Reply
Hi Hutman, thanks for the help. Unfortunately, this is one of the first things I tried and it doesn't solve the problem. Thanks anyway!
miteff replied on at Permalink Reply
Thanks Goodlyd! Please send a link on here if you find the fix. I will do the same :)
jsmrajni replied on at Permalink Reply
any one find any solution... Please help meee
kfog replied on at Permalink Reply
this seems to be an older problem. i have Not found a solution yet.
see thread: