Database not empty during GUI installation.

Permalink 0 0 Browser Info Environment
Using latest v8.5.4

After filling out the Site Information form and clicking the "Install Concret5->" button:

There are already 2 tables in this database. concrete5 must be installed in an empty database.
+--------------------------------+
| Tables_in_************* |
+--------------------------------+
| tmp_checkCollationFieldLength0 |
| tmp_checkCollationFieldLength1 |
| tmp_checkCollationFieldLength2 |
+--------------------------------+
3 rows in set (0.00 sec)

Dropping tables does not fix.

Seems this was first encountered here:https://github.com/concrete5/concrete5/issues/8338...
And the fix for v9 (develop):https://github.com/concrete5/concrete5/pull/8375...

After applying that fix it allowed me to move forward with the installation via the GUI. Have not tried the cli, but I would assume this would be present there as well.

Any chance we can gethttps://github.com/concrete5/concrete5/pull/8375... cherry-picked to master and released?

Thanks.


Status: New
markkasaboski

concrete5 Environment Information

# concrete5 Version
Core Version - 8.5.4
Version Installed - 8.5.4
Database Version - 20200609145307

# Database Information
Version: 8.0.21-0ubuntu0.20.04.4
SQL Mode: ONLY_FULL_GROUP_BY,STRICT_TRANS_TABLES,NO_ZERO_IN_DATE,NO_ZERO_DATE,ERROR_FOR_DIVISION_BY_ZERO,NO_ENGINE_SUBSTITUTION

# concrete5 Packages
None

# concrete5 Overrides
None

Browser User-Agent String

Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/85.0.4183.102 Safari/537.36