Button anchor not taking variation style

Permalink Browser Info Environment
Hi,

I'm using the Button block and when using anchor as the element type (which I think is the only element which will allow the button to link to an external URL - but please correct me if I'm wrong) it ignores the button variation style that I select under Options.

Is there a way I can create a button that links to an external URL but uses the Primary variation style?

Also, I don't suppose there's a way I can predefine the button settings for composer? I'm envisaging this block to be used a lot in composer but the user will have to repeat the settings required for the block. I don't suppose there's a way I can set a default configuration each time the block is loaded in Composer?

Thanks in advance

Type: Pre-Sale
Status: In Progress
View Replies:
ramonleenders replied on at Permalink Reply
ramonleenders
Hi there,

You should be able to use the "Variation" option with any selection under the "Element" field. Just checked that, also in the code. Do you have your website live? Also, you didn't have a custom template loaded for this Block Type by your developer (if you didn't make the site yourself that is)? It should work as expected, as is with 100 of other sites.

Kind regards,

Ramon
baysmedia replied on at Permalink Reply 3 Attachments
Hi,

The site is under construction - happy to PM you URL and credentials if needed. I'm using the Fundamental theme (which is one of the more established and popular themes in the marketplace I believe); are you aware of any issues with this block and theme combination?

I've attached screenshots of the configuration and subsequent output

I have no doubt that the add-on works well for most - I'm clearly doing something silly or have a combination that will not play nice together. But if you have any advice on how I can get the add-on to work as expected then I'd be most grateful.

Thanks
ramonleenders replied on at Permalink Reply
ramonleenders
Hi there,

This should work for most Bootstrap sites, only not for those that have modified a lot and changed (or ruined) styling... Of course, I have no influence on what other people do with their styling to your (Bootstrap) theme. If the value of the item still remains the selected "info" you have, it should work. A good way to test would be using the default "Elemental" theme instead. This as everything core from concrete5 works for (all) my Add-On(s).

I'd be happy to take a look at your website if you have a live URL. But I will probably come to the conclusion that your styling (CSS) is not correct.

Kind regards,

Ramon

concrete5 Environment Information

N/A

Browser User-Agent String

Mozilla/5.0 (Macintosh; Intel Mac OS X 10_14_3) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/73.0.3683.86 Safari/537.36

Hide Post Content

This will replace the post content with the message: "Content has been removed by an Administrator"

Hide Content

Request Refund

You may not request a refund that is not currently owned by you.