error after installion

Permalink Browser Info Environment
After installion get error with
"Declaration of Concrete\Package\Instafolio\Block\Instafolio\Controller::registerViewAssets() should be compatible with Concrete\Core\Block\BlockController::registerViewAssets($outputContent = '')"

Need help and seems this not addon not work at all.. need refund this purchace.
i not understand the problems seems always appear with your add-ons.. :/

Type: Ticket
Status: Archived
67072568252
View Replies:
ramonleenders replied on at Permalink Reply
ramonleenders
Hi there,

This is an issue with "Instafolio" (https://www.concrete5.org/marketplace/addons/instafolio-instagram-fancybox-for-concrete-5). You can see that in your message:

Concrete\Package\Instafolio\Block\Instafolio\Controller::registerViewAssets()

It's got nothing to do with Bootstrap Blocks. To fix this Add-On, go to:

/packages/instafolio/blocks/instafolio/controller.php

Search for:

registerViewAssets(){

Change that into:

registerViewAssets($outputContent = ''){

That should fix it. Then you can also notice it's not the Add-On you've just installed/bought that is having issues.

Kind regards,

Ramon
67072568252 replied on at Permalink Reply
67072568252
There is some reason for your addons, because this error occurs after bootstrap-blocks installation, before installing everything worked without any problem?
Thanks for your advice, I will try to install again..
ramonleenders replied on at Permalink Reply
ramonleenders
PHP may have been updated or the CMS itself, because this is an error originating from the core, but happening within Instafolio. I have no idea why it turns up just now, it really is not my Add-On that is causing the problems you are having right now.
67072568252 replied on at Permalink Reply
67072568252
that fix seems works.. Thank you for fast :+1:!
ramonleenders replied on at Permalink Reply
ramonleenders
You are welcome. Glad it works now!

Kind regards,

Ramon
67072568252 replied on at Permalink Reply
67072568252
Can you still check this? I did not understand to check this out first. :/ Now I'm not sure if our used theme is fully compatible with boostrap? Theme is c5box "sidebar"
ramonleenders replied on at Permalink Reply
ramonleenders
This theme:

https://www.concrete5.org/marketplace/themes/sidebar...

(http://sidebar57.c5box.com/)

Does use Bootstrap. So you should be good to go and use this Add-On.

Kind regards,

Ramon
67072568252 replied on at Permalink Reply
67072568252
ok, and thank you..
is there somewhere examples or guides for "newbies" these modals? :) Because i have small problems make those work..
ramonleenders replied on at Permalink Reply
ramonleenders
Take a look at this page:

https://www.concrete5.org/marketplace/addons/bootstrap-blocks/block-...

It describes how to set it up.

See this page for example output (so the result):

http://bootstrapblocks.devoda.nl/features/modals...

Kind regards,

Ramon
67072568252 replied on at Permalink Reply
67072568252
"In case your modal won't appear, add your "Bootstrap Modal" block near the end of the page. It could be that a theme uses different classes, where it will block/hide your modal... "

I think there is somekind of this problem, modal try appears for a moment but disappears from itself. (?)
ramonleenders replied on at Permalink Reply
ramonleenders
Can you drop it in another area maybe? Instead of "Main" (guess that is what you're doing now).
67072568252 replied on at Permalink Reply
67072568252
I try to study and try more .. mayby i can ask for advice later? :)
ramonleenders replied on at Permalink Reply
ramonleenders
Sure!

You can also add an extra area somewhere in the theme, near the bottom (outside divs).

<?php
$a = new Area('Modals');
$a->display($c);
?>


You can read more about theme developing within concrete5 here:

https://documentation.concrete5.org/developers/designing-for-concret...
67072568252 replied on at Permalink Reply
67072568252
I sent you a pm
ramonleenders replied on at Permalink Reply
ramonleenders
What happens when you set the "Animation" field to "-- None --". Does that fix it maybe?

Also navigate to this url

/index.php/dashboard/pages/bootstrap_blocks

(paste your domain in front, so something likewww.www.domain.com/index.php/dashboard/pages/bootstrap_blocks)...

Can you tell me if some checkboxes are checked here?

Kind regards,

Ramon
67072568252 replied on at Permalink Reply
67072568252
nothing.. if animation is off then modal not open at all.
67072568252 replied on at Permalink Reply
67072568252
/index.php/dashboard/pages/bootstrap_blocks
i found that earlier and already tried this .. currently there are all selected.
67072568252 replied on at Permalink Reply
67072568252
well so .. I chose everything out there, and immediately start working. No can do, i am dummy xD Thanks again..
ramonleenders replied on at Permalink Reply
ramonleenders
That would be my next suggestion, uncheck everything indeed. Really depends on the theme, since you probably installed this Add-On before with the default "Elemental" theme active.

Glad it works now!

Have fun :)

Kind regards,

Ramon
admin replied on at Permalink Reply
Attention: Since there has been no activity on this issue for two weeks, this issue has been automatically archived.

To re-open this issue, reply to this message.

concrete5 Environment Information

# concrete5 Version
Core Version - 8.2.1
Version Installed - 8.2.1

# concrete5 Cache Settings
Block Cache - On
Overrides Cache - On
Full Page Caching - On - If blocks on the particular page allow it.
Full Page Cache Lifetime - Every 30 minutes.

# Server Software
Apache/2


# PHP Version
7.0.23

Browser User-Agent String

Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:55.0) Gecko/20100101 Firefox/55.0

Hide Post Content

This will replace the post content with the message: "Content has been removed by an Administrator"

Hide Content

Request Refund

You may not request a refund that is not currently owned by you.