Modal Block Isn't Working

Permalink Browser Info Environment
Hi,

I emailed you directly earlier today but we were in a bit of a hurry so I went ahead and purchased. All looks good but I can't seem to get the modal blocks to work!

I've set up two stacks, added the modal blocks and added the bootstrap buttons. all as per your instructions. I checked the theme (Modena) and found out that it is NOT a bootstrap theme and so I went to the Bootstrap Block set up page in the dashboard and I ticked everything. Still no luck!

The page on the dev site is athttps://hereisyoursite.co.uk/icmi/index.php/modal... and I'm quite happy to set you up with access if you need it.

Am I missing something?

Thanks in advance.

Cheers,

Duncan

Type: Ticket
Status: Archived
ppisoban
View Replies:
ramonleenders replied on at Permalink Reply
ramonleenders
Hi Duncan,

So you are sure your theme is not build with Bootstrap? Because the product page of Bootstrap Blocks says:

"Bootstrap (version 3 or higher) in your theme is required for this Add-On"

The product kinda gives you anything you need in a Bootstrap theme. So if you don't use Bootstrap, you'd need to include it to be able to use stuff off of it. That means both the .js file and some styling to get the modal to show up (see here for examplehttps://getbootstrap.com/docs/3.3/javascript/#modals)....

Does that answer your questions? Is it a bought theme off the marketplace or where did you get the theme?

Kind regards,

Ramon
ppisoban replied on at Permalink Reply
ppisoban
Hi Ramon,

Thanks for the reply.

The theme is called Modena and we bought this through the marketplace. There is a support question re Bootstrap here:https://www.concrete5.org/marketplace/themes/modena/support/bootstra... and the creator says that the theme is not Bootstrap based.

As I say, I ticked all of the boxes in your set up page on the dashboard in the hope that this would load all of the resources needed.

If the theme is not a Bootstrap based theme, does this mean that there is no way to use your add on?

Many thanks.

Cheers,

Duncan
ramonleenders replied on at Permalink Reply
ramonleenders
Hi Duncan,

There is a way to use it, by as I stated including the .js and .css file that can be downloaded from Bootstrap to the theme. So you'd have to add those 2 files in order to use it. You can customize a download too (but not sure how that works on version 4, so this is for version 3):

https://getbootstrap.com/docs/3.4/customize/...

And just include /css/bootstrap.min.css and /js/bootstrap.min.js to your theme. You can perhaps uncheck a whole lot of checkboxes, if you only want to use the modals of Bootstrap though. But that's a trial and error thing for later maybe. Give it a go, scroll to the bottom of the page and download it. Add the files to your theme and see if it works afterwards. Not sure how technical you are with all this stuff, so sorry if I skipped a step or 2.

Kind regards,

Ramon
ppisoban replied on at Permalink Reply
ppisoban
Thanks for the fast reply Ramon!

I'm not in the office atm so I'll give this a go on Monday. I can be quite technical when I need to be, not too familiar with the bootstrap stuff though :)

I'll let you know how I get on.

Cheers,

Duncan
ppisoban replied on at Permalink Reply
ppisoban
Hi Ramon,

Sorry for the delay in getting back to you, it's been a busy week!

I did try to implement your solution but sadly I couldn't get it to work. We went with a different solution in the end, using the original file from teh old HTML site. It's not a big deal as this is actually an orphan page that will be referenced by 10 other sites anyway. The main thing is that it is working :)

I'm not going to be looking for a refund or anything as I'm positive that we will be able to use the add on in another project so I'll just release the license for now and transfer when we need it.

Many thanks for your help!

Cheers,

Duncan
admin replied on at Permalink Reply
Attention: Since there has been no activity on this issue for two weeks, this issue has been automatically archived.

To re-open this issue, reply to this message.

concrete5 Environment Information

# concrete5 Version
Core Version - 8.5.1
Version Installed - 8.5.1
Database Version - 20190301133300

# concrete5 Packages
Bootstrap Blocks (0.9.7), ExchangeCore reCAPTCHA (1.1.1), Location Map (1.0.11), Modena Theme (1.0.2), Responsive Embed (1.0.1), Spacer (0.9.4)

# concrete5 Overrides
None

# concrete5 Cache Settings
Block Cache - On
Overrides Cache - On
Full Page Caching - Off
Full Page Cache Lifetime - Every 6 hours (default setting).

# Server Software
LiteSpeed

# Server API
litespeed

# PHP Version
5.6.40

# PHP Extensions
bcmath, bz2, calendar, Core, ctype, curl, date, dom, ereg, exif, fileinfo, filter, ftp, gd, gettext, gmp, hash, iconv, imap, intl, ionCube Loader, json, libxml, litespeed, mbstring, mcrypt, memcache, mhash, mysql, mysqli, mysqlnd, openssl, pcntl, pcre, PDO, pdo_dblib, PDO_Firebird, pdo_mysql, PDO_ODBC, pdo_pgsql, pdo_sqlite, Phar, posix, pspell, readline, Reflection, session, shmop, SimpleXML, soap, sockets, SourceGuardian, SPL, sqlite3, standard, tokenizer, wddx, xml, xmlreader, xmlwriter, xsl, Zend Guard Loader, Zend OPcache, zip, zlib

# PHP Settings
max_execution_time - 360
log_errors_max_len - 1024
max_file_uploads - 20
max_input_nesting_level - 64
max_input_time - 360
max_input_vars - 8000
memory_limit - 256M
post_max_size - 512M
sql.safe_mode - Off
upload_max_filesize - 512M
ic24.api.max_timeout - 7
memcache.max_failover_attempts - 20
mysql.max_links - Unlimited
mysql.max_persistent - Unlimited
mysqli.max_links - Unlimited
mysqli.max_persistent - Unlimited
pcre.backtrack_limit - 1000000
pcre.recursion_limit - 100000
session.cache_limiter - <i>no value</i>
session.gc_maxlifetime - 7200
soap.wsdl_cache_limit - 5
opcache.max_accelerated_files - 7963
opcache.max_file_size - 0
opcache.max_wasted_percentage - 5
zend_optimizerplus.max_accelerated_files - 2000
zend_optimizerplus.max_file_size - 0
zend_optimizerplus.max_wasted_percentage - 5

Browser User-Agent String

Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:72.0) Gecko/20100101 Firefox/72.0

Hide Post Content

This will replace the post content with the message: "Content has been removed by an Administrator"

Hide Content

Request Refund

You may not request a refund that is not currently owned by you.