SSL redirecting to https://localhost - will Force SSL fix this?

Permalink Browser Info Environment
Hello,

I recently installed an SSL certificate on my website. It is a shared hosting plan with a dedicated IP running LiteSpeed, PHP, and MySQL.

After it installed (successfully - verified by the vendor I purchased it from), when I go the pages via http:// everything works fine. However, when I try to go a page via https:// it redirects to https:// localhost:8888.

Does anyone konw if this add-on will help correct this problem, or do I need to do something else first? I'm really excited about trying this, but I'm wondering if this will work right now.

Thank you,
-concreteart

Type: Discussion
Status: New
View Replies:
jbx replied on at Permalink Reply
jbx
Hey concreteart, thanks for your interest in the addon.

Unfortunately, ForceSSL wont solve this issue, you need to correct it before you can use the addon.

It sounds like maybe you don't have a valid virtualhost setup for the SSL side of things. I'm afraid I don't know how this works with litespeed - I'm an apache man myself...

I'd suggest contacting your host. Sounds like they are quite helpful and this definitely sounds like a config issue.

Hope you get it sorted,

Jon

concrete5 Environment Information

Browser User-Agent String

Hide Post Content

This will replace the post content with the message: "Content has been removed by an Administrator"

Hide Content

Request Refund

You have not specified a license for this support ticket. You must have a valid license assigned to a support ticket to request a refund.