Error Concrete5.8.1

Permalink Browser Info Environment
Hello,

When I upgraded to Concrete5.8.1 I got the following error:
Call to a member function getFileStorageLocationObject() on string

Type: Pre-Sale
Status: In Progress
nesoor
View Replies:
emirii replied on at Permalink Reply
emirii
Hello!

Thank you for reporting the issue. It appears that this is a bug that was introduced in Concrete5 release 8.1.0. I tried an alternative, but it did not work. So for now, I have disabled compatibility for my addon for 8.1.0 until the Concrete5 team can address my bug report.

You can find the bug report here for tracking:
https://www.concrete5.org/developers/bugs/8-1-0/fileimagebasicthumbn...

If you do not want to downgrade, or are unable to, would you like a refund? I cannot give any sort of ETA when it is fixed, and I imagine a lot of other people's galleries who are passing strings to this function is broken as well. This breaks my watermark and original image preservation functionality of my add-on.

Thank you for reporting!
nesoor replied on at Permalink Reply
nesoor
Hello emirii,

Thanks for your fast reply !
I will wait for the update :)
willingparticipant replied on at Permalink Reply
willingparticipant
Hi Emylee!
My client really likes your gallery plugin. Could you please post in this thread if and when you get it working again with Concrete5.8.1 ?

We purchased the new version for the site. Do we need to ask for a refund and then purchase when available or can we just wait until you get it working?
thanks!
emirii replied on at Permalink Reply
emirii
Hi there!

You can keep the add-on for now if you do plan on using it. The add-on will work with 8.0, but not 8.1 due to the broken changes made to the C5 core. If downgrade is a possibility for development, you can go ahead and develop with GalleryES, and when 8.2 is released that will hopefully fix this problem, you can update!

I'm glad you like it! I will keep everyone posted.
willingparticipant replied on at Permalink Reply
willingparticipant
Any progress on getting the gallery working with 5.8.1?
emirii replied on at Permalink Reply
emirii
Hi there,

The issue still hasn't been resolved even in the dev branch of Concrete5. I have been looking at alternatives but have come up short. I've been avoiding 5.8.1 as it introduced quite a few bugs in the file manager that is not related to my gallery plugin anyways. So far following the dev branch I am hopeful that they will reach my particular issue before 5.8.2 is released.

Thank you!
emirii replied on at Permalink Reply
emirii
Hello, there is a new version of GalleryES that supports 8.2 now, please update! Thanks!

For those that I provided a custom version for, please keep the version you are using unless you need watermark functionality. I am still improving GalleryES, but I do have the same version for 7.x now available for 8.2! Thanks!
olafpeter replied on at Permalink Reply
olafpeter
Hi all,
works for me. Thanks emirii....
Olaf
WillemAnchor replied on at Permalink Reply
WillemAnchor
Hi
Maybe you can create an issue on github about this problem.
Recently they did some work on the thumbnailers (maybe causing this problem), and I'm sure it would be noticed sooner on github than on the tracker.

I might be interested to use your add-on for a site I'm gonna work on. And I prefer to start with it on v8.
juddc replied on at Permalink Reply
juddc
Please do keep us posted. I was hoping to use it for a project I'm currently working on :(
WillemAnchor replied on at Permalink Reply
WillemAnchor
A release candidate for 8.2 is now availablehttp://www.concrete5.org/download...
Does this solve this problem ?
willingparticipant replied on at Permalink Reply
willingparticipant
Hey Emylee,
Any progress? we're getting close to launch and would still like to use your add-on. Can you let me know if we'll have that soon or should I begin to look around for another solution?
thanks - Mark
emirii replied on at Permalink Reply
emirii
Hey there,

I do have a working version that does not have the watermark functionality, but I obviously can't upload that with it missing one of it's core features.

If this is no problem for you, I can send you the modified files. I've been hoping for a solution officially from C5 but none yet...

If you need the watermark portion, I can take another look at it this weekend for you.
emirii replied on at Permalink Reply
emirii
It appears they fixed the particular file in 8.2.0RC2, I have yet to officially test it but that's really hopeful :)
olafpeter replied on at Permalink Reply
olafpeter
Hi emirii,
thanks for the support, can you send me the files?
(in final version 8.2
Core Version - 8.2.0
Version Installed - 8.2.0
it still apears)
thanks, olaf
willingparticipant replied on at Permalink Reply
willingparticipant
Not really concerned about the watermark just need the plugin to work.
thanks!
emirii replied on at Permalink Reply
emirii
Hi all, please give a little more time (the end of the week?) as I am switching from generating thumbnails on the fly to using the thumbnail system native to C5 now. Since you both don't need watermark, it should not take too much longer to get to a usable point! It's also improved in the management side, now uses ajax saving :)
willingparticipant replied on at Permalink Reply
willingparticipant
Hurray!!
olafpeter replied on at Permalink Reply
olafpeter
Hi, any good news?
willingparticipant replied on at Permalink Reply
willingparticipant
Well, after holding out hope that GalleryES would be a solution for our client’s site soon, we’re still finding that It’s not completely working with 8.x (or 8.2.1 for that matter) and we have to move on. Downgrading to an earlier version won’t work for us in their new site build, so how can we go about getting a refund? Please let me know what information you need from us. Thanks.
Mark
emirii replied on at Permalink Reply
emirii
I am so sincerely sorry for delaying this as long as it has. It's been a hay ride here and now preparing for Hurrican Harvey (I am in direct path), and an upcoming surgery, on top of losing my hosting account and everything on it due to a terrible company, things have gotten quite insane. I'm not normally this flakey!

I believe both of you are due for a refund, and I will be PMing you the plugin as-is for you to use on your projects. Most functionality works aside from the watermark, bulk edit options in the "manage" area (rotate/crop/watermark/etc.), and if you want to change the thumbnail size and crop, you will have to edit the "gallery_e_s_gallery" in "System & Settings > Files > Thumbnails".

I've been working hard to get it as usable and with as many working features as possible, but recent events are making that very hard. I also stress a great deal about the quality of my code which doesn't help much either ;(.

If you find any errors or bugs, PM me or leave a note here and I will address it ASAP!

I looked up the refunds, and apparently, Concrete5 does not store purchases for refunds indefinitely... Please PM me your Paypal address for the refund.
olafpeter replied on at Permalink Reply
olafpeter
wish you the best!
klemen69 replied on at Permalink Reply
Hi i have same problem after upgrading from 7 to 8.2.1

Is there any way to downgrade to 8.0 or even 7?

thanks

klemen

concrete5 Environment Information

On the page were the block is added

Browser User-Agent String

Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/57.0.2987.74 Safari/537.36

Hide Post Content

This will replace the post content with the message: "Content has been removed by an Administrator"

Hide Content

Request Refund

You may not request a refund that is not currently owned by you.