Problem with the icons

Permalink Browser Info Environment
The icons work perfectly when logged in but when I log out the icons disappear.

Type: Pre-Sale
Status: In Progress
View Replies:
jordif replied on at Permalink Reply

then I guess your theme is not loading Font Awesome.

You see, the plugin makes it easy to insert Font Awesome icons, but does not load Font Awesome for you (it assumes your theme is already loading it).

Some themes (such as Elemental) load Font Awesome out of the box. The concrete5 dashboard also loads Font Awesome (that's why you see the icons while you're logged in).

To add support for Font Awesome in your theme, you'll need to do the following:

1. Open your theme folder and edit the file "page_theme.php".

2. Find the function registerAssets() and add the following line inside the function:

$this->requireAsset('css', 'font-awesome');

I'll add a note to the marketplace page to clarify this.

Hope this helps,

nesoor replied on at Permalink Reply
Hello Jordif,

thank you for your fast reply! it works now!
nesoor replied on at Permalink Reply
Hey Jordif,

I installed Concrete5 8.1 and installed your addon but it doesn't work anymore.
Are you going to update it?

I really like this addon and I do appreciate your work !
jordif replied on at Permalink Reply

I think Redactor has been replaced by CKEditor in 5.8, that's why it is not working.

.This is a plugin for Redactor, so it would be necessary to create a new add-on with a plugin for CKEditor ("Icons for CKEditor"). Not sure if I'll have the time to do this, you could try posting this in the Block Requests forum.


nesoor replied on at Permalink Reply
Hello jordif,

Thanks for your fast reply !
I will post this in the block request :)

concrete5 Environment Information

When logged out

Browser User-Agent String

Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/49.0.2623.75 Safari/537.36

Hide Post Content

This will replace the post content with the message: "Content has been removed by an Administrator"

Hide Content

Request Refund

You have not specified a license for this support ticket. You must have a valid license assigned to a support ticket to request a refund.