Thumbnail
Intrusion Detection System

Developed by

Expert
Expert

Version 8 ready!

This is a developer resource for site owners licensed by GPL.

You want to protect your site against cyber-attacks? Then the Intrusion Detective System add-on is what you are looking for!

The Intrusion Detection System add-on for concrete5 protects your site against common known cyber-attacks like SQL Injections, XSS attacks and over 70 more. The protection is immediately active once you have installed it. In the settings, you can customize the filters, enable / disable logging and add email notifications. In addition, you can even choose a custom error page for the attackers. This add-on is based on the PHPIDS library. It combines the power of this library with the easy handling of concrete5. The add-on is multilingual and available in German and English language.

More details you will find here.

Important notice: This add-on is not an all-in-one protection solution. It is rather a supporting protective measure. Also, the included library PHPIDS is no longer maintained.

Have you already seen my other add-ons? Click here for more information.

See more of my addons

Current Version: 0.9.2.0
Fully Translatable: Yes
Needs External Libraries: No
Compatible 5.7.0.4+
License: GPL
Support Response: Replies to tickets every few days.
Support Hosted: At External Website
Needs extra server permissions: No
Needs Internet: No
Marketplace Tests:
Passed Automated Tests
Passed PRB Review