Exception error after install

Permalink Browser Info Environment
Hi,

I just purchased and installed Page Password and am getting an exception error. I don't know if it is the same as other errors in this list, but I am currently unable to use the plug-in. Could you please assist?

Error:
Whoops \ Exception \ ErrorException (E_WARNING)
count(): Parameter must be an array or an object that implements Countable

I can provide further diagnostic info if necessary.
thanks

Type: Ticket
Status: Archived
View Replies:
hanicker replied on at Permalink Reply
hanicker
Hi, sorry for this problem, can you please try installing this updated package instead?

https://drive.google.com/file/d/1hNPcs4AesiNL4g9dpFW77uDMZdpRCnUL/vi...

Thanks in advance
Regards
bayleafmedia replied on at Permalink Reply 1 Attachment
That fixed it. However, I am unable to edit the password with needed. The only option available is to remove it entirely. That is something I would need to have fixed before January if possible.

Other than that I think we are good to go.

thanks for your help
hanicker replied on at Permalink Reply
hanicker
Unfortunately there are no planned releases for new features, we only keep it maintaned in case of new c5 versions.

Thanks
Regards
bayleafmedia replied on at Permalink Reply
Thanks,

The version that came from the marketplace had that feature. When I set pages to require a password it both hid the password (with a link to show), and then two buttons (one blue and one red) to either edit or remove that password.

Do you mean that in the version you provided for me to download will not have receive those features?

thanks
hanicker replied on at Permalink Reply
hanicker
Hi, previous versions (expecially for c5 5.4) had the ability to change password but the current one doesn't have it as the password is encrypted in the database (this was explicitly requested by the c5 team for security reasons) so the view/edit feature was removed. The passwords set can't be retrieved in any way for viewing or editing now.

Thanks
Regards
bayleafmedia replied on at Permalink Reply
Gotcha, so the version in the marketplace is out of date?

thanks for the help. I think my issue is solved. I appreciate it.
hanicker replied on at Permalink Reply
hanicker
Hi, sorry for this late reply.

Yes the old c5 version does not support the new package.

Thanks
Regards
admin replied on at Permalink Reply
Attention: Since there has been no activity on this issue for two weeks, this issue has been automatically archived.

To re-open this issue, reply to this message.

concrete5 Environment Information

# concrete5 Version
Core Version - 8.5.4
Version Installed - 8.5.4
Database Version - 20200609145307

# Database Information
Version: 5.7.29-log
SQL Mode: NO_ENGINE_SUBSTITUTION

# concrete5 Packages
ACME (4.2.8), Block Designer (3.3.0), Customize Editing Interface (1.0.1), Easy Image Gallery (1.4.2), Easy Social Feed (1.1.5), Fundamental (4.0.7), Image Optimizer (3.2.11), Instant Page Speed Magic (1.1.2), Magic Tabs (7.2.0), MailChimp Subscribe (3.0), Mega Menu (1.6.4), Page password (0.9.3), Responsive Embed (1.0.1), Simple Gallery (1.0.9), SVG Social Media Icons (0.9.9), Vimeo Video (1.1), Whale Responsive Tables (1.2.1)

# concrete5 Overrides
blocks/blbc_staff/add.php, blocks/blbc_staff/composer.php, blocks/blbc_staff/config.json, blocks/blbc_staff/controller.php, blocks/blbc_staff/db.xml, blocks/blbc_staff/edit.php, blocks/blbc_staff/form.php, blocks/blbc_staff/icon.png, blocks/blbc_staff/view.php, blocks/blbc_staff, blocks/blbc_staff_block/add.php, blocks/blbc_staff_block/composer.php, blocks/blbc_staff_block/config.json, blocks/blbc_staff_block/controller.php, blocks/blbc_staff_block/db.xml, blocks/blbc_staff_block/edit.php, blocks/blbc_staff_block/form.php, blocks/blbc_staff_block/icon.png, blocks/blbc_staff_block/view.php, blocks/blbc_staff_block, blocks/blbc_staffblock/add.php, blocks/blbc_staffblock/composer.php, blocks/blbc_staffblock/config.json, blocks/blbc_staffblock/controller.php, blocks/blbc_staffblock/db.xml, blocks/blbc_staffblock/edit.php, blocks/blbc_staffblock/form.php, blocks/blbc_staffblock/icon.png, blocks/blbc_staffblock/view.php, blocks/blbc_staffblock, blocks/blbcstaffblock/add.php, blocks/blbcstaffblock/composer.php, blocks/blbcstaffblock/config.json, blocks/blbcstaffblock/controller.php, blocks/blbcstaffblock/db.xml, blocks/blbcstaffblock/edit.php, blocks/blbcstaffblock/form.php, blocks/blbcstaffblock/icon.png, blocks/blbcstaffblock/view.php, blocks/blbcstaffblock

# concrete5 Cache Settings
Block Cache - On
Overrides Cache - On
Full Page Caching - On - If blocks on the particular page allow it.
Full Page Cache Lifetime - Every 6 hours (default setting).

# Server Software
Apache

# Server API
cgi-fcgi

# PHP Version
7.3.11

# PHP Extensions
bcmath, bz2, calendar, cgi-fcgi, Core, ctype, curl, date, dom, exif, fileinfo, filter, ftp, gd, gettext, hash, iconv, imagick, imap, intl, json, libxml, mbstring, memcached, mysqli, mysqlnd, openssl, pcntl, pcre, PDO, pdo_mysql, pdo_sqlite, Phar, posix, pspell, Reflection, session, SimpleXML, soap, sockets, sodium, SPL, sqlite3, standard, tokenizer, xml, xmlreader, xmlrpc, xmlwriter, xsl, zip, zlib

# PHP Settings
max_execution_time - 500
log_errors_max_len - 1024
max_file_uploads - 20
max_input_nesting_level - 64
max_input_time - 500
max_input_vars - 1000
memory_limit - 300M
post_max_size - 300M
upload_max_filesize - 300M
mbstring.regex_stack_limit - 100000
memcached.sess_lock_max_wait - not set
memcached.sess_lock_wait_max - 2000
memcached.sess_server_failure_limit - 0
mysqli.max_links - Unlimited
mysqli.max_persistent - Unlimited
pcre.backtrack_limit - 1000000
pcre.recursion_limit - 100000
session.cache_limiter - <i>no value</i>
session.gc_maxlifetime - 7200
soap.wsdl_cache_limit - 5

Browser User-Agent String

Mozilla/5.0 (Macintosh; Intel Mac OS X 10_14_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/86.0.4240.75 Safari/537.36 Edg/86.0.622.38

Hide Post Content

This will replace the post content with the message: "Content has been removed by an Administrator"

Hide Content

Request Refund

You may not request a refund that is not currently owned by you.