Button to external URL link does not work.

Permalink Browser Info Environment
The external link button to a slide is set to open a new window, but nothing happens when I press it. When a press right mouse button on it, it DOES open the window.
What can I do?

Type: Ticket
Status: Resolved
lvbaal
View Replies:
shahroq replied on at Permalink Reply
shahroq
Can you provide me a live link?
lvbaal replied on at Permalink Reply 1 Attachment
lvbaal
http://www.trondenesdagene.no/index.php/artister

Oeps, the site is not live, i.e. the ¨under maintenance¨ flag is on. Do you have a way to circumvent this maybe?

If not, can you send me a pm, so I can give you login details...

I could also send you the source file of this page of course
shahroq replied on at Permalink Reply
shahroq
Plz send me your site credentials via private message.
lvbaal replied on at Permalink Reply
lvbaal
________________________________
Fra: concrete5 Community <[email protected]>
Sendt: 5. oktober 2017 20:27
Til: [email protected]
Emne: Button to external URL link does not work. : Support
lvbaal replied on at Permalink Reply
lvbaal
shahroq replied on at Permalink Reply
shahroq
You should specify the type of link (External, Internal) then specify a link. I did for the first item and now the link working.
lvbaal replied on at Permalink Reply
lvbaal
lvbaal replied on at Permalink Reply
lvbaal
The link was working before, when specified ¨Slide¨, it's not working when ¨Button¨ is specified. Can you look into this again? Thanks!
shahroq replied on at Permalink Reply
shahroq
In both states (Button or Slider) you should select Url Type (Internal or External) and a valid Url. I edited the second slide (Victor Sordo Vicente), so it should be clear what u should do for other slides.
lvbaal replied on at Permalink Reply
lvbaal
Hello and thanks again for your support.

I see the button with text ¨Les mer¨, but it's still not opening the external link upon clickinghttps://en.wikipedia.org/wiki/Carlos_Mena...

I have tried both Google Chrome and MS Edge on Windows and Safari on iPhone.

Am I missing somting here?

Leo
lvbaal replied on at Permalink Reply
lvbaal
shahroq replied on at Permalink Reply
shahroq
Hi,
As i see it works fine, maybe it's your browser cache, press Ctrl+F5 and see if it fixes the issue.
lvbaal replied on at Permalink Reply
lvbaal
Okay, that did the trick. Thanks again!
TeKnoZiz replied on at Permalink Reply
TeKnoZiz
No, it is still not working for me, I have done what you asked, although I had done that before and it does not appear to work. I am on Chrome on an iMac. Button responds but does not navigate to the link. I also tried it in IE, Edge, Firefox, Safari and Chrome on the PC and nothing.
TeKnoZiz replied on at Permalink Reply
TeKnoZiz
I cleared the C5 cache and it nows appears to be working... somewhat. Still reviewing the slide links.
shahroq replied on at Permalink Reply
shahroq
What version of Owl you are using? Did you upgrade to latest version?
TeKnoZiz replied on at Permalink Reply
TeKnoZiz
Just installed latest version and cleared the cache. Buttons still don’t work. When you click on them they stay highlighted now, but don’t go anywhere. This is on an iPad. Will check desktop later.
lvbaal replied on at Permalink Reply
lvbaal
When you say ¨cleared the cache¨, do you mean in Concrete5 controlpanel or in your web browser on PC / mobile? My issue was solved anyway after clearing cache on PC AND pressing <CTRL>F5 on the webpage.
shahroq replied on at Permalink Reply
shahroq
Please provide a live link.
TeKnoZiz replied on at Permalink Reply
TeKnoZiz
Just checked my desktop and the buttons appear to work. Maybe clearing the cache on the iPad will allow it to work as well. Yes I was referring to the C5 cache at the time. Live link:

http://marinerseafood.com/gowild/...
shahroq replied on at Permalink Reply
shahroq
I checked the page on ios and it works just fine.
TeKnoZiz replied on at Permalink Reply
TeKnoZiz
Great, thanks! Will confirm on my end. Appreciate the help.

concrete5 Environment Information

# concrete5 Version
Core Version - 8.2.1
Version Installed - 8.2.1
Database Version - 20170802000000

# concrete5 Packages
Bethel Theme (1.1.3), PDF Viewer (1.0.1), Under Construction (1.0.1), Whale OWL Carousel (2.5.7.8)

# concrete5 Overrides
None

# concrete5 Cache Settings
Block Cache - Off
Overrides Cache - Off
Full Page Caching - Off
Full Page Cache Lifetime - Every 6 hours (default setting).

# Server Software
Apache

# Server API
cgi-fcgi

# PHP Version
7.0.12

# PHP Extensions
bcmath, bz2, calendar, cgi-fcgi, Core, ctype, curl, date, dom, exif, fileinfo, filter, ftp, gd, gettext, hash, iconv, imagick, imap, intl, json, libxml, mbstring, mcrypt, mysqli, mysqlnd, openssl, pcntl, pcre, PDO, pdo_mysql, pdo_sqlite, Phar, posix, readline, Reflection, session, shmop, SimpleXML, soap, sockets, SPL, sqlite3, standard, tidy, tokenizer, wddx, xml, xmlreader, xmlrpc, xmlwriter, xsl, zip, zlib

# PHP Settings
max_execution_time - 30
log_errors_max_len - 1024
max_file_uploads - 20
max_input_nesting_level - 64
max_input_time - 60
max_input_vars - 1000
memory_limit - 128M
post_max_size - 200M
sql.safe_mode - Off
upload_max_filesize - 200M
mysqli.max_links - Unlimited
mysqli.max_persistent - Unlimited
pcre.backtrack_limit - 1000000
pcre.recursion_limit - 100000
session.cache_limiter - <i>no value</i>
session.gc_maxlifetime - 7200
soap.wsdl_cache_limit - 5

Browser User-Agent String

Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/61.0.3163.100 Safari/537.36

Hide Post Content

This will replace the post content with the message: "Content has been removed by an Administrator"

Hide Content

Request Refund

You may not request a refund that is not currently owned by you.