Free Shipping (again)

Permalink Browser Info Environment
Hey JohntheFish!

I swear I did research this before reaching out (again). I was reading your thread here:
http://www.concrete5.org/marketplace/addons/zone-based-shipping/for...

I'm trying to offer free shipping. I tried to follow what you said in the thread, but I keep getting an error (I've attached it).

Alright. I know it's me. What am I doing wrong?

Thanks JohntheFish! :)

1 Attachment

Type: Discussion
Status: New
rainmaker
View Replies:
JohntheFish replied on at Permalink Reply
JohntheFish
There was a bug on this, introduced a couple of minor versions ago. So most likely all you need to do is update to the latest ZBS (1.9.0.2 at the moment)
JohntheFish replied on at Permalink Reply
JohntheFish
PS.

It may actually be complaining that you have empty rules in the Value column, and not about the 0 cost on the first rule.
rainmaker replied on at Permalink Reply
rainmaker
Wait. What? I'm supposed to have "$ Value up to" column set as 0 and the "$ cost by" to 50? I thought the $cost by was how much the shipping was for the user. No?
rainmaker replied on at Permalink Reply
rainmaker
I also updated and it's not working still...
JohntheFish replied on at Permalink Reply
JohntheFish
No, I didn't mean the columns were back to front. Just that there were also empty entries in the value column.

However, I have now run more tests and created a some rows identical to your screengrab and can't duplicate the error. So I doubt if it is the empty entries in the value column that are responsible.

Can you please open a support request (so I have all your environment info) and also attach an export of your rules as a txt file. That way I can import the entire rules to a test system and see if there is anything causing this not visible in the screengrab.
rainmaker replied on at Permalink Reply
rainmaker
You know what John? I got it. My mind wasn't clicking that the rules I established were for from $0 - $50. I was thinking $50+

My bad. Sorry about that. I knew I was doing something wrong.

concrete5 Environment Information

Browser User-Agent String

Hide Post Content

This will replace the post content with the message: "Content has been removed by an Administrator"

Hide Content

Request Refund

You have not specified a license for this support ticket. You must have a valid license assigned to a support ticket to request a refund.