Top navigation problem

Permalink Browser Info Environment
Hi.
Suddenly my top navigation started to make a new row in Safari (mac), but it shows correctly in other browsers.
What can be the problem? See attached image.
/Peter

1 Attachment

Type: Discussion
Status: In Progress
View Replies:
c5box replied on at Permalink Reply
c5box
Hi Peter,

I took a look at your site on safari and the menu is displaying correctly. Did you manage to figure it out?

Please don't hesitate to let me know if you need more help.

Kind regards,
James
peel1962 replied on at Permalink Reply
Hi James. Sorry to say, but no I didn´t. It´s still two rows in the menu and I don´t have a clue.
I am using your theme on two other websites and it looks fine on them.
/Peter
peel1962 replied on at Permalink Reply
Hi again. One more thing happened (I saw this just now). The dropdown menu doesn´t work either and they work fine in the other two sites and i`m using the same settings there.
I haven´t changed anything in the autonav block.
/Peter

Funny, I saw in the autonav block that the settings was somehow changed to not showing subpages. Especially when I wasn´t working in that block.
But still, I don´t get rid of the "row situation".

/Peter
c5box replied on at Permalink Reply 1 Attachment
c5box
Hi Peter,

Is this the site your are working on? alfagruppen.se

Can't seem to see the issue on safari. See attached.

Can you provide me with temporary access so I can investigate? I hope that's alright.

Kind regards,
James
peel1962 replied on at Permalink Reply
Sorry for not being clear. It´s a site youcall.se. You can find it here:http://d33217395.u154.surf-town.net/index.php...
The DNS is not pointed to the url yet.
c5box replied on at Permalink Reply
c5box
Hi Peter,

It's difficult to know what's causing it. Can you remove and re-add a new navigation with the right custom nav template. Also, this looks like another css attribute is causing it on safari. Can you remove any/all custom css you added on your site including inline styles via areas and blocks.

Let me know how it works out.

Regards,
James
peel1962 replied on at Permalink Reply 1 Attachment
Hi James.
I have tried what you suggested and theres is no change. If you want to have a look in the code I can give you my ftp-login, but not here in public.
Email me on [email protected] and I´ll return with my login info.

This is how your demo site is rendered with my gear (macbook pro retina, thunderbolt display 27") MacOS Sierra). See attached image.

Could be a problem connected to Safari/Mac, but why are my other sites with you theme working?http://www.alfagruppen.se andhttp://www.revisionaren.se
Strange

/Peter
peel1962 replied on at Permalink Reply
Hi again. The site youcall.se is now pointed to the right DNS servers so I don´t know if the temporary url is working.

Just curious, did you see my problem (and on your site as well)?
/Peter
c5box replied on at Permalink Reply
c5box
Hi Peter,

My email might not have reached you. Can you private message me here the login details for that site? I still can't figure out what's causing it. Hopefully we can fix this soon.

Kind regards,
James
peel1962 replied on at Permalink Reply
Hi James. You´ve got a PM
/Peter
tachymeter replied on at Permalink Reply 2 Attachments
Hi guys,

I have noticed that I have some kind of the same issues with the header menue while using safari. As you can see in the attached files, either the search link or the contact link are shifted into a second row for no reason. The screenshots are taken on two different computers. Is there any solution to avoid that problem?

Thanks for any information!
c5box replied on at Permalink Reply
c5box
Hi,

This issue has been fixed on the latest version. Kindly update your theme and everything should work the way it normally does. :)

Kind regards,
James
tachymeter replied on at Permalink Reply
Hi James,
I have just updated both concrete 5 and Framework theme, but the "search" symbol is still in a second row on Safari. Do you know any other solution?

Thanks, Stefanie
c5box replied on at Permalink Reply
c5box
Hi Stefanie

I've checked your site on safari and does not have the broken nav anymore. Can you clear your browsers cache or turn private browsing mode on to check? :)

Thanks and regards
James

concrete5 Environment Information

# concrete5 Version
Core Version - 5.7.5.9
Version Installed - 5.7.5.9
Database Version - 20160615000000

# concrete5 Packages
Framework Theme (1.4.5), Login/Logout Link (1.0), Login Page Background (0.9).

# concrete5 Overrides
languages/da_DK/LC_MESSAGES/messages.mo, languages/da_DK/LC_MESSAGES, languages/da_DK, languages/fi_FI/LC_MESSAGES/messages.mo, languages/fi_FI/LC_MESSAGES, languages/fi_FI, languages/nb_NO/LC_MESSAGES/messages.mo, languages/nb_NO/LC_MESSAGES, languages/nb_NO, languages/de_DE/LC_MESSAGES/messages.mo, languages/de_DE/LC_MESSAGES, languages/de_DE, languages/pl_PL/LC_MESSAGES/messages.mo, languages/pl_PL/LC_MESSAGES, languages/pl_PL, languages/el_GR/LC_MESSAGES/messages.mo, languages/el_GR/LC_MESSAGES, languages/el_GR, languages/pt_BR/LC_MESSAGES/messages.mo, languages/pt_BR/LC_MESSAGES, languages/pt_BR, languages/fr_FR/LC_MESSAGES/messages.mo, languages/fr_FR/LC_MESSAGES, languages/fr_FR, languages/es_PY/LC_MESSAGES/messages.mo, languages/es_PY/LC_MESSAGES, languages/es_PY, languages/ru_RU/LC_MESSAGES/messages.mo, languages/ru_RU/LC_MESSAGES, languages/ru_RU, languages/ja_JP/LC_MESSAGES/messages.mo, languages/ja_JP/LC_MESSAGES, languages/ja_JP, languages/sv_SE/LC_MESSAGES/messages.mo, languages/sv_SE/LC_MESSAGES, languages/sv_SE, languages/tr_TR/LC_MESSAGES/messages.mo, languages/tr_TR/LC_MESSAGES, languages/tr_TR, languages/nl_NL/LC_MESSAGES/messages.mo, languages/nl_NL/LC_MESSAGES, languages/nl_NL, languages/it_IT/LC_MESSAGES/messages.mo, languages/it_IT/LC_MESSAGES, languages/it_IT, languages/da_DK/LC_MESSAGES/messages.mo, languages/da_DK/LC_MESSAGES, languages/da_DK, languages/fi_FI/LC_MESSAGES/messages.mo, languages/fi_FI/LC_MESSAGES, languages/fi_FI, languages/nb_NO/LC_MESSAGES/messages.mo, languages/nb_NO/LC_MESSAGES, languages/nb_NO, languages/de_DE/LC_MESSAGES/messages.mo, languages/de_DE/LC_MESSAGES, languages/de_DE, languages/pl_PL/LC_MESSAGES/messages.mo, languages/pl_PL/LC_MESSAGES, languages/pl_PL, languages/el_GR/LC_MESSAGES/messages.mo, languages/el_GR/LC_MESSAGES, languages/el_GR, languages/pt_BR/LC_MESSAGES/messages.mo, languages/pt_BR/LC_MESSAGES, languages/pt_BR, languages/fr_FR/LC_MESSAGES/messages.mo, languages/fr_FR/LC_MESSAGES, languages/fr_FR, languages/es_PY/LC_MESSAGES/messages.mo, languages/es_PY/LC_MESSAGES, languages/es_PY, languages/ru_RU/LC_MESSAGES/messages.mo, languages/ru_RU/LC_MESSAGES, languages/ru_RU, languages/ja_JP/LC_MESSAGES/messages.mo, languages/ja_JP/LC_MESSAGES, languages/ja_JP, languages/sv_SE/LC_MESSAGES/messages.mo, languages/sv_SE/LC_MESSAGES, languages/sv_SE, languages/tr_TR/LC_MESSAGES/messages.mo, languages/tr_TR/LC_MESSAGES, languages/tr_TR, languages/nl_NL/LC_MESSAGES/messages.mo, languages/nl_NL/LC_MESSAGES, languages/nl_NL, languages/it_IT/LC_MESSAGES/messages.mo, languages/it_IT/LC_MESSAGES, languages/it_IT

# concrete5 Cache Settings
Block Cache - On
Overrides Cache - On
Full Page Caching - Off
Full Page Cache Lifetime - Every 6 hours (default setting).

# Server Software
LiteSpeed

# Server API
litespeed

# PHP Version
5.6.28

# PHP Extensions
bcmath, bz2, calendar, Core, ctype, curl, date, dom, ereg, exif, fileinfo, filter, ftp, gd, gettext, hash, iconv, imap, intl, json, libxml, litespeed, mbstring, mcrypt, memcache, mhash, mysql, mysqli, mysqlnd, openssl, pcntl, pcre, PDO, pdo_mysql, pdo_pgsql, pdo_sqlite, pgsql, Phar, posix, Reflection, session, shmop, SimpleXML, soap, sockets, SPL, sqlite3, standard, tokenizer, turbo_realpath, XCache, XCache Cacher, xml, xmlreader, xmlrpc, xmlwriter, xsl, Zend OPcache, zip, zlib.

# PHP Settings
max_execution_time - 3000
log_errors_max_len - 1024
max_file_uploads - 20
max_input_nesting_level - 64
max_input_time - 60
max_input_vars - 5000
memory_limit - 1024M
post_max_size - 100M
sql.safe_mode - Off
upload_max_filesize - 100M
memcache.max_failover_attempts - 20
mysql.max_links - Unlimited
mysql.max_persistent - Unlimited
mysqli.max_links - Unlimited
mysqli.max_persistent - Unlimited
pcre.backtrack_limit - 1000000
pcre.recursion_limit - 100000
pgsql.max_links - Unlimited
pgsql.max_persistent - Unlimited
session.cache_limiter - <i>no value</i>
session.gc_maxlifetime - 1440
soap.wsdl_cache_limit - 5
RealPath safe mode - <i>no value</i>
realpath_cache_safe_mode - <i>no value</i>
xcache.var_maxttl - 0
opcache.max_accelerated_files - 4000
opcache.max_file_size - 0
opcache.max_wasted_percentage - 5

Browser User-Agent String

Mozilla/5.0 (Macintosh; Intel Mac OS X 10_12_1) AppleWebKit/602.2.14 (KHTML, like Gecko) Version/10.0.1 Safari/602.2.14

Hide Post Content

This will replace the post content with the message: "Content has been removed by an Administrator"

Hide Content

Request Refund

You may not request a refund that is not currently owned by you.