Install fail....

Permalink Browser Info Environment
I bought and installed, or tried to install, the Loft theme. There was an error message that I should have gotten a screen shot of, and now the result is that the theme is partially installed. By that I mean that the Add Functionality page and the environment information above both indicate that Loft is installed, but the Themes page and the Theme selector under the Attributes tab on individual pages do not display Loft as an option. Any idea how I can fix that and get this installed?

Type: Ticket
Status: Archived
scrivener
View Replies:
jsantaga replied on at Permalink Reply
jsantaga
Hey Scrivener,

Just wanted to say thank you for your loft purchase and that your bug has been received and I am working on a fix. Unfortunately though it might not be uploaded until Sunday evening. I will be sure to update you as soon as the install fix is in place but just wanted to let you know your issue is being addressed.

- Jordan
jsantaga replied on at Permalink Reply
jsantaga
Hey Scrivener,
Looks like you are using version 5.7.5, if you plan on keeping your existing Concrete5 version I can create a fix for you as it's not available in the version history of LOFT in the marketplace. Otherwise, you can upgrade your Concrete5 site and LOFT will most likely install correctly. Please let me know what best suits your needs, thanks!

- Jordan
scrivener replied on at Permalink Reply
scrivener
Thanks, Jordan! I'll try running the upgrade on c5 and report back.
scrivener replied on at Permalink Reply
scrivener
Trying to 'update concrete5' I get this URL--xxx/dashboard/system/backup/update--and a blank page. No further action. What's my next move?
scrivener replied on at Permalink Reply
scrivener
One other question: When/if I get the c5 update sorted out, should I uninstall/reinstall the Loft package? Or will updating c5 smooth everything out?
jsantaga replied on at Permalink Reply
jsantaga
Hey Andrew,
You may need to manually upgrade Concrete5 if for some reason your automatic upgrade isn't working. Not sure why that would be off of the top of my head.

To answer your question though, do a quick uninstall of LOFT and re-install once the C5 upgrade is done, I think that will be required in order to successfully install all of LOFT and it's features or sample content.

Just let me know if you get stuck with this and I'll be happy to shoot you my email and we can get to the bottom of this issue! Thanks again!

- Jordan
scrivener replied on at Permalink Reply
scrivener
I've never done a manual upgrade before (never had the automatic upgrade fail...). Are there instructions for that somewhere on this site? Guess I'll go look around....
scrivener replied on at Permalink Reply
scrivener
Actually, on rethink, you mentioned that you could create a fix that would work with my version of c5. I didn't have any previous plans to upgrade; how much of an imposition would it be for you to create that fix? :-)
jsantaga replied on at Permalink Reply
jsantaga
Hey Andrew,

Not a problem, let me spin up a version of C5 5.7.5 and see if I can get that error. If so, then I'll upload the patched versions of the LOFT files or find a way to send them to you directly. Sorry for the hassle here and yeah, it's definitely a little odd that the automatic upgrade didn't work but oh well :/ I'll keep you posted.

- Jordan
jsantaga replied on at Permalink Reply
jsantaga
Hey Andrew,
Working on this but just as an aside, you may want to think about upgrading your PHP version as well. I see you're using version 5.4 and that's a couple versions out of the PHP lifecycle, which could potentially put you at risk, just wanted to give you a heads up! Trying to spin up and old version of PHP and C5 5.7 to get you this fix, bear with me

- Jordan
jsantaga replied on at Permalink Reply 1 Attachment
jsantaga
Ok Andrew, I believe I have a fix for your install issue! Looks like it was related to the 'entity' namespace added to newer versions of C5 for image thumbnails. I have updated this and successfully just installed on C5 v5.7.5. I think that your easiest bet is to probably replace the LOFT package in your '/packages' directory of your C5 website and re-install LOFT. I've attached the .zip file to this message but have also included it in the C5 version compatibility for the LOFT theme. If you get stuck during the update let me know and I can hop in to take it the rest of the way there. Hope this does the trick for you!

- Jordan
scrivener replied on at Permalink Reply
scrivener
THANK YOU SO MUCH!!

Just delete the theme folder in the /packages directory and replace it with the contents of this zip?
jsantaga replied on at Permalink Reply
jsantaga
Yes indeed, that should do the trick. Then try the re-installation process and please do let me know how it goes :)

- Jordan
jsantaga replied on at Permalink Reply
jsantaga
Hey Andrew,

Just out of curiosity, did you get LOFT set up and working? Just looking to close the support ticket if I can :)

- Jordan
scrivener replied on at Permalink Reply
scrivener
Working on that right now. Just a sec....
scrivener replied on at Permalink Reply
scrivener
Observation #1: I can only upgrade to php 7.1, which Hostgator tells me is deprecated. If I switch to 7.2 I get a blank screen instead of a page load. No error message, nada. But switch it back to 7.1 and it loads fine. That's with the old theme, so maybe I needed to upgrade that theme but it's not an issue anymore since I won't be using it anymore. Would you recommend I upgrade php again once I get Loft installed?
scrivener replied on at Permalink Reply
scrivener
Observation #2: Running php7.1, it looks like the c5 upgrade is working again, and I'm tempted to give it a shot just because I can, but I really want to get the theme thing nailed down first.

Observation #3: Now I was able to uninstall and re-install Loft through the dashboard. It's like everything's working, mostly.

Observation #4: There's something I don't understand about how switching themes works (never had to do it before, never had a client change design specs in mid-build...), because I can switch back and forth between the two themes, but they are not reading the database the same way, and none of my content is loading in Loft (other than the basic page structure, sitemap, and what looks like a jumbled mess of nav info at the top of the pages). So I've got it switched back to the other theme for now so at least I can see my content.

I don't know exactly what's appropriate here, but I'm thinking close this ticket (you solved the problem I gave you), and I'll PM you about where to go from here. Many thanks!!
jsantaga replied on at Permalink Reply
jsantaga
Awesome news, I'll close the ticket and am following up with you privately regarding some of your other issues. No worries, we'll get to the bottom of this!

- Jordan
admin replied on at Permalink Reply
Attention: Since there has been no activity on this issue for two weeks, this issue has been automatically archived.

To re-open this issue, reply to this message.

concrete5 Environment Information

# concrete5 Version
Core Version - 5.7.5.13
Version Installed - 5.7.5.13
Database Version - 20160615000000

# concrete5 Packages
Framework Theme (1.7.4), LOFT (1.0.0)

# concrete5 Overrides
languages/sv_SE/LC_MESSAGES/messages.mo, languages/sv_SE/LC_MESSAGES, languages/sv_SE, languages/es_PE/LC_MESSAGES/messages.mo, languages/es_PE/LC_MESSAGES, languages/es_PE, languages/de_DE/LC_MESSAGES/messages.mo, languages/de_DE/LC_MESSAGES, languages/de_DE, languages/es_PY/LC_MESSAGES/messages.mo, languages/es_PY/LC_MESSAGES, languages/es_PY, languages/da_DK/LC_MESSAGES/messages.mo, languages/da_DK/LC_MESSAGES, languages/da_DK, languages/it_IT/LC_MESSAGES/messages.mo, languages/it_IT/LC_MESSAGES, languages/it_IT, languages/nl_NL/LC_MESSAGES/messages.mo, languages/nl_NL/LC_MESSAGES, languages/nl_NL, languages/ru_RU/LC_MESSAGES/messages.mo, languages/ru_RU/LC_MESSAGES, languages/ru_RU, languages/fi_FI/LC_MESSAGES/messages.mo, languages/fi_FI/LC_MESSAGES, languages/fi_FI, languages/el_GR/LC_MESSAGES/messages.mo, languages/el_GR/LC_MESSAGES, languages/el_GR, languages/en_GB/LC_MESSAGES/messages.mo, languages/en_GB/LC_MESSAGES, languages/en_GB, languages/ja_JP/LC_MESSAGES/messages.mo, languages/ja_JP/LC_MESSAGES, languages/ja_JP, languages/es_ES/LC_MESSAGES/messages.mo, languages/es_ES/LC_MESSAGES, languages/es_ES, languages/pt_BR/LC_MESSAGES/messages.mo, languages/pt_BR/LC_MESSAGES, languages/pt_BR, languages/cs_CZ/LC_MESSAGES/messages.mo, languages/cs_CZ/LC_MESSAGES, languages/cs_CZ, languages/tr_TR/LC_MESSAGES/messages.mo, languages/tr_TR/LC_MESSAGES, languages/tr_TR, languages/pl_PL/LC_MESSAGES/messages.mo, languages/pl_PL/LC_MESSAGES, languages/pl_PL, languages/fr_FR/LC_MESSAGES/messages.mo, languages/fr_FR/LC_MESSAGES, languages/fr_FR, languages/nb_NO/LC_MESSAGES/messages.mo, languages/nb_NO/LC_MESSAGES, languages/nb_NO, languages/sv_SE/LC_MESSAGES/messages.mo, languages/sv_SE/LC_MESSAGES, languages/sv_SE, languages/es_PE/LC_MESSAGES/messages.mo, languages/es_PE/LC_MESSAGES, languages/es_PE, languages/de_DE/LC_MESSAGES/messages.mo, languages/de_DE/LC_MESSAGES, languages/de_DE, languages/es_PY/LC_MESSAGES/messages.mo, languages/es_PY/LC_MESSAGES, languages/es_PY, languages/da_DK/LC_MESSAGES/messages.mo, languages/da_DK/LC_MESSAGES, languages/da_DK, languages/it_IT/LC_MESSAGES/messages.mo, languages/it_IT/LC_MESSAGES, languages/it_IT, languages/nl_NL/LC_MESSAGES/messages.mo, languages/nl_NL/LC_MESSAGES, languages/nl_NL, languages/ru_RU/LC_MESSAGES/messages.mo, languages/ru_RU/LC_MESSAGES, languages/ru_RU, languages/fi_FI/LC_MESSAGES/messages.mo, languages/fi_FI/LC_MESSAGES, languages/fi_FI, languages/el_GR/LC_MESSAGES/messages.mo, languages/el_GR/LC_MESSAGES, languages/el_GR, languages/en_GB/LC_MESSAGES/messages.mo, languages/en_GB/LC_MESSAGES, languages/en_GB, languages/ja_JP/LC_MESSAGES/messages.mo, languages/ja_JP/LC_MESSAGES, languages/ja_JP, languages/es_ES/LC_MESSAGES/messages.mo, languages/es_ES/LC_MESSAGES, languages/es_ES, languages/pt_BR/LC_MESSAGES/messages.mo, languages/pt_BR/LC_MESSAGES, languages/pt_BR, languages/cs_CZ/LC_MESSAGES/messages.mo, languages/cs_CZ/LC_MESSAGES, languages/cs_CZ, languages/tr_TR/LC_MESSAGES/messages.mo, languages/tr_TR/LC_MESSAGES, languages/tr_TR, languages/pl_PL/LC_MESSAGES/messages.mo, languages/pl_PL/LC_MESSAGES, languages/pl_PL, languages/fr_FR/LC_MESSAGES/messages.mo, languages/fr_FR/LC_MESSAGES, languages/fr_FR, languages/nb_NO/LC_MESSAGES/messages.mo, languages/nb_NO/LC_MESSAGES, languages/nb_NO

# concrete5 Cache Settings
Block Cache - On
Overrides Cache - On
Full Page Caching - Off
Full Page Cache Lifetime - Every 6 hours (default setting).

# Server Software
Apache

# Server API
cgi-fcgi

# PHP Version
5.4.45

# PHP Extensions
bcmath, bz2, calendar, cgi-fcgi, Core, ctype, curl, date, dom, ereg, exif, fileinfo, filter, ftp, gd, gettext, gmp, hash, iconv, imagick, imap, intl, ionCube Loader, json, libxml, mbstring, mcrypt, mhash, mssql, mysql, mysqli, odbc, openssl, pcre, PDO, pdo_mysql, pdo_sqlite, Phar, posix, pspell, Reflection, session, SimpleXML, soap, sockets, SourceGuardian, SPL, sqlite3, standard, tidy, tokenizer, wddx, xml, xmlreader, xmlrpc, xmlwriter, xsl, Zend Guard Loader, zip, zlib

# PHP Settings
max_execution_time - 30
log_errors_max_len - 1024
max_file_uploads - 20
max_input_nesting_level - 64
max_input_time - 60
max_input_vars - 1000
memory_limit - 256M
post_max_size - 260M
sql.safe_mode - Off
upload_max_filesize - 256M
mssql.max_links - Unlimited
mssql.max_persistent - Unlimited
mssql.max_procs - Unlimited
mssql.textlimit - Server default
mysql.max_links - Unlimited
mysql.max_persistent - Unlimited
mysqli.max_links - Unlimited
mysqli.max_persistent - Unlimited
odbc.max_links - Unlimited
odbc.max_persistent - Unlimited
pcre.backtrack_limit - 1000000
pcre.recursion_limit - 100000
session.cache_limiter - <i>no value</i>
session.gc_maxlifetime - 1440
soap.wsdl_cache_limit - 5

Browser User-Agent String

Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:79.0) Gecko/20100101 Firefox/79.0

Hide Post Content

This will replace the post content with the message: "Content has been removed by an Administrator"

Hide Content

Request Refund

You may not request a refund that is not currently owned by you.