Unable to install on Uniform Server - file info extension issue

Permalink
Hi all,
I try to install the latest concrete5 (5.7.0.2) on a Uniform Server (which is a XAMPP alternative). I'm running it at Windows XP on a virtualbox. (it worked with a test setup with other CMSs, so this is not the problem)

The first install page, 'Testing required items' says the 'File Info Extension' is disabled. How do I enable this? My Uniform Server runs PHP v5.4.30, so this should already be enabled? I also added a php5.ini file as described here:http://www.concrete5.org/community/forums/installation/no-installat... , otherwise the checking hangs.


Thanks in advance,
-S

View Replies:
pixel8 replied on at Permalink Reply
pixel8
I am having the same issue, but just on my host (recommended by the C5 team) Webhostinghub - and they say, that they have no intention of installing it soon. :-(

Is this extension mandatory or can you install C57 someway despite missing this extension?
107studio replied on at Permalink Reply
107studio
I am trying to install C5.7.0.3 and can't pass the initial test page also. File Info Extension needs to be enabled. I added the line extension=fileinfo.so into my php.ini, still says it's disabled. I have php v5.3.29 installed.

EDIT: My sites are hosted at namecheap.com I asked them and they said you can only enable file info with a VPS system, doesn't work with shared hosting.

So 5.7 isn't meant to work on shared hosting?
Remo replied on at Permalink Reply
Remo
It's not so much about shared hosts or not. That module is installed on all the shared hosts we're using..

The dependency gets added by flysystemhttps://github.com/thephpleague/flysystem... The question is whether they change their library to work without finfo.. As far as I can see, this should be possible but one would have to rewrite a bit of code, or add some fallback code..
pixel8 replied on at Permalink Reply
pixel8
so... what will I miss, if I install 5.7 anyway? (which I did - and have not encountered any fatal errors yet?)
Remo replied on at Permalink Reply
Remo
Haven't tested it, but I assume some file manager features like a thumbnail based on the file type might be broken.. Stuff related to the mime-type of files.
ATSolutions replied on at Permalink Reply
Is the file info extension issue still a problem on Concrete5.7.3. Been waiting to install my new portfolio site built with concrete5.7. However this instance of concrete5 would not install on my hosting service (Using inmotion web hosting.) do to this issue.
enlil replied on at Permalink Reply
enlil
Its been fixed in newer versions. Not positive which version it was that fixed it though. Happened over a month ago...
ATSolutions replied on at Permalink Reply
Great thanks for the info. Will updated to the latest version now.
enlil replied on at Permalink Reply
enlil
I'm experiencing the same issue on bluehost. I've been trying to install ANY of the new versions for over a week now and can't get a single successful install out of any of them :|
enlil replied on at Permalink Reply
enlil
Has anyone found a solution for this? I'm at wits end. I'm on a bluehost vps and no matter what i seem to do with a php.ini file, like 107studio mentions, it will not work. Tech support told me I should be able to edit the setting from within my cpanel but It's not an option :|
Remo replied on at Permalink Reply
Remo
as mentioned above, you'll have to update parts of flysystem. Either that or get a host where you can use fileinfo..
enlil replied on at Permalink Reply
enlil
I guess the point i failed to mention is that bluehost is one of c5's recommended hosts and it's currently not working. Maybe we can get franz on the phone with them in the morning? :D
Remo replied on at Permalink Reply
Remo
well, that's bad ;-)
something has to change I guess.. Since I'm not using bluehost, I'm not going to update the code, selfish I know (-:
enlil replied on at Permalink Reply
enlil
From bluehost tech support: "No plans to add it by default. Its not included in a default WHM, it has to be manually enabled."

Had to manually install it in whm and all is well!
Remo replied on at Permalink Reply
Remo
Dizenjo replied on at Permalink Reply
I have this issue on inmotion hosting as well and the fix isn't simple.http://www.inmotionhosting.com/support/community-support/general-se...

Would very much like to get this CMS working to see if it's a viable option to build sites with, but looks like a dead end for now.
PineCreativeLabs replied on at Permalink Reply
PineCreativeLabs
I'm also having this same problem. InMotion Hosting, trying to install 5.7.0.4.

This is strange, as I had no issue at all installing 5.7.0.1.
cleverington replied on at Permalink Reply
cleverington
Just to add to this, UK2.net who are a UK based web hosting company, have just sent this reply...

"That extension isn't on our servers and there aren't any current plans to put it on there as it is a very complicated process. If you want to add this extension and make any other similar customizations then I suggest you get a dedicated server. UK2 does offer dedicated hosting."

Oh Dear, 4 years of using C5 down the pan unless we can fix it :-(
Remo replied on at Permalink Reply
Remo
There's a fix in the flysystem repo, but it's not merged yet because I'm having a hard time to properly unit test it..
cleverington replied on at Permalink Reply
cleverington
Remo, is there anything I can do to test it. Im not a developer, but I can give you access to a shared location where you can test it if that helps?
juddc replied on at Permalink Reply
juddc
Same issue over here. Had to ask my webhost to enable it.

Edited to say: They told me they've installed it - I'm still getting the error message though. 5.7.0.4
juddc replied on at Permalink Reply
juddc
Got it sorted and installed - then got this on the homepage:

PHP Startup: fileinfo: Unable to initialize module Module compiled with module API=20090626 PHP compiled with module API=20100525 These options need to match.

The error is leaving the install fairly unuseable.
bek replied on at Permalink Reply
I have started a thread on this problem also. Unfortunately my hosts tells me there is no way they are going to enable phps file info extension as it has security vulnerability issues (see this for more info:http://stackoverflow.com/questions/22423437/php-fileinfo-extension-... ) Is this extension ALWAYS going to be needed for C5 now as it doesn't sound too good re: security nevermind the fact that I'm going to have to stop using future versions of C5?

I've already had to use v5.6.3.2 to start my new project because of this when I really wanted to use v5.7.0.4.
Remo replied on at Permalink Reply
Remo
Check my comment above, there's a fix but I can't get unit testing working and don't have the time to work on it right now.
bek replied on at Permalink Reply
Hi Remo,

Thanks for letting me know. I really hope this can be sorted out soon as I have lots of clients using C5 who eventually will want to upgrade to 5.7.* and with this issue it's going to be a pain.
Remo replied on at Permalink Reply
Remo
well, there's no upgrade path at the moment anyway... And keep in mind that 99.9% of the add-ons haven't been ported to 5.7 yet.
whitecliffs replied on at Permalink Reply
Hi,

I thought I would also add that I am unable to install 5.7.0.4 for the same reason as noted here.

File info extension not enabled.

My install is on Dreamhost running PHP 5.4

Thanks,
Ben
jasteele12 replied on at Permalink Reply
jasteele12
The solution on Dreamhost using PHP 5.4 FastCGI (the default version) is quite simple. Replace USERNAME below with your actual Dreamhost username of course.

In your /home/USERNAME/ create a .php/ directory (if it doesn't already exist) and then create a 5.4/ directory under that.

Next create a file called phprc (also if it doesn't already exist) and add this:

; /home/USERNAME/.php/5.4/phprc - overrides for /etc/php54/php.ini
;;; concrete5 5.7 = currently required!!! :(
extension=fileinfo.so


Then wait a few minutes (or kill any active php54.cgi processes) and run the install again. That's it!

* Of course if you aren't able to use the command line, you could create this directory structure under say Windows: php\5.4\ and add the above in a phprc file, FTP upload the php directory tree to your home directory and rename php/ to .php/ (note it has to begin with a dot).

If you'd like me to do it, send me a PM ;)

John
whitecliffs replied on at Permalink Reply
Hi John,

Thanks for the info.

I had tried your suggestion before I originally posted after researching a solution online but it unfortunately did not help.

I will wait for the next release and hope that this dependency is addressed.

Thanks,
Ben
jasteele12 replied on at Permalink Reply
jasteele12
@Sh0ck - Uniform server is quite different than the *nix hosting replies above.

php5.ini has nothing to do with it, and probably all you have to do is uncomment a line in your php.ini file and restart the Apache server.

Depending on where you installed it (I put mine in C:\uni\) it will looks something like this:

c:\uni\usr\local\php\php.ini

The line you want to uncomment (remove the starting semicolon) will look like this:

;extension=php_fileinfo.dll

Let us know what happens - John

P.S. Feel free to mark this as best answer ;)
Sh0cK replied on at Permalink Reply
@jasteele123
Perhaps you're using another version of Uniform Server.
I don't have the folder "usr". I also made a windows search for "php.ini" in the Uniform folder, returning no results.
I'm using UniServer Zero XI 11.2.1 ;
UniController XI V.1.1.5 .

Any other suggestions?
Dizenjo replied on at Permalink Reply
The php.ini file is not always automatically available. I just had a website that required modifying this file for another reason and I had to contact my hosting service to have it made visible and available to edit.
mhawke replied on at Permalink Reply
mhawke
You can enable/disable modules by first turning off Apache and going to 'PHP -> Edit Basic and Modules -> PHP Modules Enable/Disable'.

http://screencast-o-matic.com/watch/c26UoQel2i...