Dashboard Permissions Nightmare!

I cannot find any concise documentation on narrowing the access capability for Groups to the various parts of the Dashboard.

I have configured permissions for a Group all the way to the 'Full Sitemap' page, the use can login, navigate to it but when they select 'Full Sitemap' they get the error:

"You do not have access to the sitemap."

Any ideas? I'd really appreciate some guidance on exactly which permissions are required on all parent pages to the sub-page that you need to give edit access to in the Dashboard?

Also, is there an easy way to reset all permissions so that I can start again? I would love to see a feature where you could tick a box when amending the permissions of a parent to reset ALL child pages.

View Replies: View Best Answer
julia replied on at Permalink Reply
Hi there, To set dashboard page permissions, go to Dashboard > Sitemap, click options and check the box for show system pages. That will reveal a section called Dashboard. Click on the dashboard page or section you want the group to be able to access and choose Set Permissions--then give the group permission to View the page. That should do the trick.
sergeant replied on at Permalink Reply
Thanks Julia, but I have already done this, and applied the same to every parent page up through the structure. I suspected that it was a bug in the permissions system and so upgraded to the latest release, but still get this error?

So for someone to have the ability to manage a section of the admin area, they only need 'View' rights?
julia replied on at Permalink Best Answer Reply
There are a few other places you need to set these permissions.

1. System & Settings > Permissions & Access > File Manager Permissions

2. System & Settings > Permissions & Access > Task Permissions
(This is where you enable sitemap permissions)

The View permission for the dashboard is all they need to get the Dashboard button and have access to most of the dashboard pages.

Oh, if you want them to have access to add or search users, those permissions are at:
System & Settings > Permissions & Access > User Permissions
sergeant replied on at Permalink Reply
Thanks Julia, perfect - it was the 'Task Permissions' that I hadn't set. How odd hiding this away when it could simply be configured in the same way as handling permissions for the rest of the dashboard, fairly inconsistent!

Thanks again!
TMDesigns replied on at Permalink Reply
Will all this only work when you have advanced permissions switch on? Or can it work with basic permissions?
julia replied on at Permalink Reply
I believe it works with simple permissions. Also, here's a better tutorial on how to set up dashboard permissions: