Usergroup Editors access to Dashboard-File-Manager-Page not working - SOLVED

Permalink
Hello

I have built a website for a client with concrete5 version 8.4.4. The client wants access to edit page contents, but no more. For this purpose I set up a Usergroup 'Editors' with limited permissions.

Everything fine, just access to the File-Manager-Page is not working.

When I log in as an 'Editor', I can access the File Manager through the links provided in the blocks in edit mode, this way uploading a file is working.

But how do I delete the uploaded file again as an 'Editor', when access to the File Manager is only working through blocks in edit-mode?

Beside the concrete5-documentation on 'Advanced Permissions' I have also found and set the permissions following these documents:

=>https://documentation.concrete5.org/tutorials/letting-editors-get-fi...

=>https://www.concrete5.org/community/forums/usage/a-link-to-the-file-...

=>https://www.concrete5.org/community/forums/customizing_c5/setting-da...

I enclose some screenshots to show my actual permission settings (task permissions, file permissions, etc.). The website is set up in german, so the usergroup 'Editors' is called 'Inhaltautoren' in the screenshots.

I cleared cache through Dashboard > System & Settings. I even deleted everything in the folders application/files/cache and application/files/tmp with no success.

One thing I noticed, is the fact, that when 'Advanced Permissions' is turned on, some system pages in the sitemap, for instance 'stacks', inherit the permissions from the page 'home'. I changed these to 'manually', but left 'My Account' to inherit permissions from 'home' in order to allow 'Editors' to see it in their sitemap.

Now the strange thing is, logged in as 'Editor' I can see 'My Account' in the sitemap only, when I have turned on 'Show System Pages' logged in as 'admin'. I enclose two screenshots to show the sitemap I can see logged in as 'Editor', one with 'admin' having 'Show System Pages' turned on, and one, 'admin' having 'Show System Pages' turned off. As 'Editor' I don't have the option to turn system pages on /off.

What am I missing? How do I grant 'Editors' access to the file-manager-page in order to manage their own files directly in the file manager, outside edit-mode on pages?

Any input will greatly be appreciated, thanks in advance.

6 Attachments

View Replies:
mnakalay replied on at Permalink Reply
mnakalay
Although I have zero German, it seems you didn't give your Editors group the right to delete files in your File Manager Permissions screenshot (3rd screenshot labeled file-permissions.png)

Under System & Einstellugen > Dateien > Dateiberechtigungen
the permission for Datei Löschen is not given to the group Inhaltautoren, it is given to the group Datei-Upload instead. That might be the problem
dessisan replied on at Permalink Reply
Hello and thanks for your input.

I had given access to 'Delete File'-permission to the group 'File Uploader' after studying this tutorial:

=>https://documentation.concrete5.org/editors/dashboard/system-and-mai...

The idea was, that 'Editors' can view all files within the file manager and use them for site content, but only delete files, they have upload themselves.

Thinking about what you wrote I thought: "Ok. Maybe with my permission settings the file-manager-page shows up for an editor in his sitemap only, if he has already uploaded at least one file, because without having uploaded own files, there is no sense for him to access the file-manager-page, say the file manager directly."

So I logged in as an editor, uploaded a picture-file and put it on a page. That worked, but still no access to the file manager directly.

Then I followed your suggestion, logged in as 'admin', deleted the group 'File Uploader' in delete-file-permissions and added instead the group 'Editors'. Then I cleared cache through dashboard system & settings. Nothing changed.

So I logged in again as 'admin', turned as 'admin' in the sitemap 'Show System Pages' on and deleted through control panel access everything in the folder application/files/cache. Nothing changed.

Logged in as editor I can see in the sitemap 'My Account' because having turned on 'Show System Pages' as 'admin', but there is still not the file-manager-page in the sitemap.

Unfortunately I don't see yet how to access the file manager as an editor in order to delete the picture-file I uploaded as the same editor before.

Sorry.

Maybe you or somebody else has another idea?
dessisan replied on at Permalink Reply 1 Attachment
SOLVED

At last I managed to set up permissions as I wanted to.

The trigger point for editors to access the file manager in order to fully manage own files, e.g. also delete own uploaded files, was to grant the usergroup 'Editors' not only access to the system page 'File Manager', but also grant them access to the parent system page 'Dashboard'.

In order to deny 'Editors' access to other dashboard-pages this made necessary to change the setting 'Assign permissions' on all other dashboard-pages from standard 'By Area of Site (Hierarchy)' to 'Manually' and give only 'Administrators' permissions on these other dashboard-pages.

This way editors have access to the file manager, but no other dashboard-pages (see attached screenshot).